Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

nsd3 is very little-known but super-lightweight and stable DNS server which makes it a great alternative to bind9 be used on low-end boxes. There is a very good tutorial here that describe how to set it up. My problem is that I need to set up a subdomain subd1.example.com that will be severed on another VPS. I tried to add

subdmn1.mymaindomain.com. IN 1.2.3.5
(Assuming that my destination IP is 1.2.3.5) Then I

nsdc rebuild
service nsd3 restart

However the subdmn1.mymaindomain.com fails to resolve to the IP. Any clues will be much appreciated.

share|improve this question
add comment

1 Answer

If that's exactly the record from your zonefile, you are missing the record type, and possibly the TTL.

The correct way would be:

subdmn1.mymaindomain.com. 86400 IN A 1.2.3.5

It might be possible to skip the TTL - I have never tried this in nsd.

If this still does not resolve your problem, have a look in the nsd logs. Note that you don't have to restart to reload the zones, you can use nsdc reload after the nsdc rebuild.

Also, assuming that this record is in the mymaindomain.com., zone, you could shorten subdmn1.mymaindomain.com. to subdmn1 (note the lack of a trailing dot there).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.