Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I tried to install passenger using rvm and ruby 1.9.2 on my debian lenny/sid today, but i get this error:

 apache2: Syntax error on line 295 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/conf.d/passenger.conf: 
 Cannot load /home/username/.rvm/gems/ruby-1.9.2-p136/gems/passenger-3.0.2/ext/apache2/mod_passenger.o into server: /home/username/.rvm/gems/ruby-1.9.2-p136/gems/passenger-3.0.2/ext/apache2/mod_passenger.o:   
 only ET_DYN and ET_EXEC can be loaded
   ...fail!

RVM was installed with

 bash < <( curl http://rvm.beginrescueend.com/releases/rvm-install-head )

after changing the bashrc I installed passenger with

 rvm install 1.9.2
 rvm default 1.9.2
 gem install passenger
 rvmsudo passenger-install-apache2-module

and than I added the lines printed out at the end into the passenger.conf.

What does the error mean? How can I get it running?

share|improve this question
    
What does file /home/username/.rvm/gems/ruby-1.9.2-p136/gems/passenger-3.0.2/ext/apache2/mod_pa‌​ssenger.o say? uname -a? –  DerfK Jan 22 '11 at 15:16
    
file says this: .rvm/gems/ruby-1.9.2-p136/gems/passenger-3.0.2/ext/apache2/mod_passenger.o: ELF 64-bit LSB relocatable, x86-64, version 1 (SYSV), not stripped and uname says this: 2.6.18-028stab070.7 #1 SMP Fri Oct 1 13:53:00 MSD 2010 x86_64 GNU/Linux –  bitboxer Jan 22 '11 at 15:32
    
For some reason the apache2 module compile failed. Apache modules should be "shared objects" (usually .so extension) which are the ET_DYN mentioned in the error message. Not sure why passenger-install-apache2-module isn't telling you that. Perhaps there's a "verbose" flag you can use? –  DerfK Jan 22 '11 at 15:51
add comment

1 Answer

up vote 0 down vote accepted

Strangly the passenger instalation was somehow damaged. I went into the passenger dir and compiled the module by hand using rake apache2 and after that I changed the .o into .so and now it's working perfectly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.