Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Not sure what I did, but for some reason the network adapter no longer shows up in my guest os running Ubuntu. When I run ifconfig, only the lo interface is listed. The Network Adapter settings for the guest is this:

screenshot

What's going on?


ifconfig -a

ifconfig -a

dmesg | grep -i eth

dmesg | grep -i eth

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

Try

dmesg | grep -i eth

If you see kernel messages mentioning network hardware, then the interface is being detected by the kernel. It may just be that you've messed up your user-land configuration.

Is your guest OS Ubuntu Desktop? If so, check your network settings in the Network Manager applet. Create a new entry there for your interface, if one doesn't already exist.

If you're not running Network Manager (or some other graphical network config applet like wicd), then your network probably needs to be configured in the /etc/network/interfaces file. Presuming your network interface is named eth0, and presuming your LAN has a functioning DHCP server, the following entry in your guest's interfaces file should do the trick:

auto eth0
iface eth0 inet dhcp
share|improve this answer
    
The guest is running Ubuntu Server, and there is no gui installed. My host is running Windows 7. Added screenshot of the output. Not sure what's going on there... eth0 is mentioned twice and then it says that it's renamed to eth2 O.o –  Svish Jan 22 '11 at 21:16
    
@Svish: What has happened is that at some point, you changed the (virtual) network card that VirtualBox presents to the guest VM, and the guest's udev has renamed the device to something other than eth0. You can either just accept that your network interface is now named eth2 (and modify your interfaces file accordingly), or you can tell udev to forget about your previous network card named eth0, and name your current card eth0. –  Steven Monday Jan 22 '11 at 23:04
    
How would I do this? –  Svish Jan 23 '11 at 13:54
1  
@Svish: I described two options. If you want the former, just edit your /etc/network/interfaces to configure eth2 instead of eth0. If you want the latter, edit /etc/udev/rules.d/70-persistent-net.rules, removing all entries for your existing and previous network cards, and then reboot. –  Steven Monday Jan 23 '11 at 16:46
1  
Tried that last option with removing all the entries from the rules file, and that after rebooting the interface is back :) Thanks! –  Svish Jan 24 '11 at 8:30
add comment

and what do you get with "ifconfig -a" ? If network is not properly set up, you may not see the unused interface.

share|improve this answer
    
Added screenshot of output. And an eth2 shows up? The HWaddr matches the MAC address assigned in the settings, so it's the same network adapter at least. And it's there. But at the same time it's not. I'm lost :p –  Svish Jan 22 '11 at 21:17
add comment

I wish I had a better answer, but bridging to wireless adapters really has some issues with most virtualization products. Try switching your guest network mode to NAT and see if the adapter shows up in your guest.

share|improve this answer
    
I have switched it back to all the different modes, but still nothing shows up. –  Svish Jan 22 '11 at 21:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.