Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got an odd problem that I'm not really sure where to start the troubleshooting process.

I have a 'server' with Windows Server 2008R2 (64-bit) installed and it has a couple of hard drives. If I Remote Desktop into the server and transfer files from one HD to the other, all it fine.

If however, I use my workstation (Windows 7 64bit) and open up a shared resource on the server and transfer a file from one hard drive on the server to another HD on the server (not using Remote Desktop, just Windows explorer/Network places), the transfer crawls... It takes about 5mins to discover files/calculate the transfer and then starts transferring at speeds like 56KB/s - 200KB/s.

Both machines have Marvel GigE network ports with a TrendNet 8-port green GigE switch. I've set Jumbo packets to 9K on both machines...

share|improve this question
add comment

3 Answers

Disk to disk copies on the same machine are not impacted by the same service overhead, or network considerations, as network copies. It's even faster if the disks are two physically different disks, rather than 2 partitions.

That being said, I've seen several complaints about Vista and 7 with network copying. One of the recommendations from a Microsoft tech (cannot remember the source) is to disable the autotuninglevel. This can be done from a command prompt.

  • Click start, in the run/search box, type cmd, and hit CTRL+SHIFT+ENTER (this is needed if you have UAC enabled).
  • In the prompt that opens, type netsh int tcp set global autotuninglevel=disabled
  • Restart your computer.

If that doesn't help, you can turn back the options by changing disabled to normal and restarting again.

As a side note, when copying from driveA to driveB on the same server, but via a network share, the data has to stream to the client, then back to the server. This is essentially doubling the actual amount of data being transferred.

share|improve this answer
add comment

I would suspect driver trouble, try looking for updated drivers, firmware or different NICs.

share|improve this answer
add comment

Network copy also adds TCP/IP overhead as every TCP packet will carry 32byte header. So actual processed data, not just copied, will be twice as data itself plus significant amount of networking overhead.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.