Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to setup a hudson server which is accessed from an apache proxy. The Hudson index page loads but no images, css or javascript are loaded. It seems as relative paths are not working correctly. My current apache configuration for the proxy is the following:

/etc/apache2/available-sites/default:

<VirtualHost *:8000>
    [...]
    #Hudson
    RewriteEngine On
    ProxyPass         /hudson  http://localhost:8081
    ProxyPassReverse  /hudson  http://localhost:8081
    ProxyRequests     Off
    ProxyPreserveHost On

    <Proxy *>
        Order deny,allow
        Allow from all
    </Proxy>
</VirtualHost>

The next screenshot shows how the hudson index is displayed:

(don't have enough reputation to post the image sorry, but imagine the hudson index with no images or css, just black text and blue links)

I think the problem is in my apache config but I can't find any information about this error.

Thanks in advance.

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

Use "--prefix=/hudson" in /etc/default/hudson and:

ProxyPass         /hudson  http://localhost:8081/hudson
ProxyPassReverse  /hudson  http://localhost:8081/hudson

or

ProxyPass         /  http://localhost:8081
ProxyPassReverse  /  http://localhost:8081
share|improve this answer
    
When Hudson is down Apache shows: Service Temporarily Unavailable but when I start hudson It wont load anything –  eliocs Jan 23 '11 at 12:21
    
Is there any more output or logs I could get for this situation? –  eliocs Jan 23 '11 at 12:37
    
Your answer is correct! But my hudson froze because of the continuous restarts, THANKS :D –  eliocs Jan 23 '11 at 14:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.