Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to add the atomic repo to CentOS. I run:

sudo wget -q -O - http://www.atomicorp.com/installers/atomic | sh

All seems to go fine.

However, when I look in /etc/yum.repos.d it's not there. And when I try to install anything with yum, it doesn't appear to be looking in the atomic repo.

EDIT 1

It's CentOS 5

share|improve this question
    
I'm tempted to reconstruct the installation manually from the script. Which CentOS release? –  Scott Pack Jan 23 '11 at 13:27
    
@packs Do you mean you would be tempted to not use the atomic repo and get the source and compile and install it by hand? –  John Simon Ritchie Jan 23 '11 at 13:46
add comment

2 Answers

After reviewing that install script, I noticed a few issues that will prevent it from working. There are a few times where it tries to download files that result in an HTTP 404 error, including the actual the repository RPM! Based on the install script, you should only need to execute the following commands to successfully install the repository.

This will first install the GPG key Shinn uses to sign the packages, second download and install the files necessary to use the atomic repository, and third install the additional plesk repository. Replace $ARCH in step 2 with the output of the command uname -i, and step 3 is only necessary if you also want plesk.

  1. rpm --import http://www.atomicrocketturtle.com/RPM-GPG-KEY.art.txt
  2. rpm -Uvh http://atomicorp.com/channels/atomic/centos/5/$ARCH/RPMS/atomic-release-1.0-13.el5.art.noarch.rpm
  3. wget -q -O /etc/yum.repos.d/plesk.repo http://atomicorp.com/installers/repos/plesk-centos-8.repo
share|improve this answer
    
That gave me: error: skipping atomicorp.com/channels/atomic/centos/5/i386/RPMS/… - transfer failed - Unknown or unexpected error –  John Simon Ritchie Jan 23 '11 at 15:44
    
Have you tried downloading it first, then installing it? –  Scott Pack Jan 23 '11 at 15:50
add comment

My guess is, it isn't working because you have sudo in the wrong spot.

You currently have:

sudo wget -q -O - http://www.atomicorp.com/installers/atomic | sh

Which applies the sudo command to the wget command, but by the time it is piped into the sh, it's lost its root privileges. If you move the sudo over, it should work.

So, give this one a try:

wget -q -O - http://www.atomicorp.com/installers/atomic | sudo sh
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.