Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I install rabbitMQ in synaptic via the following command

sudo apt-get install rabbitmq-server

it returns an error:

Starting rabbitmq-server: FAILED - check /var/log/rabbitmq/startup_log, _err
invoke-rc.d: initscript rabbitmq-server, action "start" failed.
dpkg: error processing rabbitmq-server (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Going to the logs, it says the following:

Error: {cannot_connect_to_epmd,"herman-desktop",address}

while my /etc/hosts is defined as follows: localhost.localdomain localhost
::1 herman-desktop localhost6.localdomain6 localhost6 herman-desktop

What do I need to do to fix this?

share|improve this question
up vote 7 down vote accepted

You have the "herman-desktop" configured in /etc/hosts to the localhost address in ipv6 only, since rabbitmq is running ipv4 it won't be able to connect, edit /etc/hosts and add herman-desktop (your machine name I suppose) to the line of (localhost on ipv4)

Also unless you have configured on your machine it looks like a type to me :)

share|improve this answer
Thanks, but it's still not working. Could you please provide an example of how that line should look? Also, is really configured, but don't ask me why – Herman Jan 23 '11 at 15:49
It seems ubuntu 12.04 configures to the hostname of the of the pc by default – Sam Stoelinga Apr 4 '13 at 10:18

Best way is to tell rabbitmq to not to look for hostname. You can do that using rabbitmq config file.

edit config, create it if it does not exist

vim /etc/rabbitmq/rabbitmq.conf
vim /etc/rabbitmq/rabbitmq-env.conf (in later versions of RabbitMQ)

Add following entries:

share|improve this answer
thx, was stuck with starting the server, this solved it! – hoberion Mar 21 '11 at 12:16
This did it for me, seems to be the least invasive solution. – jondavidjohn Mar 4 '13 at 4:33

This happened to me when I changed the hostname while installing chef-server. I reverted back to the old hostname, killed running rabbitmq processes, purged rabbitmq package, then re-run chef-solo bootstrap of chef-server.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.