Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A standard procedure when someone receives a computer upgrade for our company is to do a P2V copy of their old one, in case we miss something important on their new machine.

This has worked flawlessly for years, but the most recent P2V conversion we've done has had an adverse affect on Windows Genuine Validation. It re-activated just fine, but 20 minutes later:

Windows not valid

It's not a huge issue (they're really just there for safety purposes and spend most of their life shut down) but it's a bit unprofessional when you're presented with that message when you log in.

share|improve this question
Was the Windows license purchased through volume licensing or as OEM? – Nic Jan 24 '11 at 0:43
@Nic - OEM license (from the bottom of the laptop, not the VL key that they come pre-shipped with) – Mark Henderson Jan 24 '11 at 1:12
@Nic - I just changed it to a spare key from our technet subscription but it's the same story. – Mark Henderson Jan 24 '11 at 1:34
Weird. Maybe try doing a full sysprep and re-entering the key? That should make it happy with the virtual hardware. – Nic Jan 24 '11 at 1:38
Windows will flip out when you make large changes to the hardware, a P2V would certainly cause this. What kind of license was this? – BenGC Jan 24 '11 at 2:57
up vote 5 down vote accepted

So, it turns out my first activation was too soon. I activated it as soon as the activation window showed up, but on a subsequent restart the VM was re-configured by SCVMM which caused the VM to become invalidated.

For whatever reason, the Genuine Validation tool didn't detect that a re-activation was all that was required. I ran slui manually and forced the activation, and all the messages went away.

Moral of the story: Don't reactivate a Windows 7 VM running with SCVMM until you're sure it's finished re-configuring the guest.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.