Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Not sure what the terminology is for it but on Vim the 'cursor' is always like an insert/replace cursor instead of the blinking line cursor I'm used to in other gui editors. Is there any way to change this when in insert mode?

share|improve this question
    
Please don't cross-post. –  Dennis Williamson Jan 24 '11 at 2:38

3 Answers 3

up vote 1 down vote accepted

If you are talking about vim inside a shell, you should configure the cursor style in your terminal emulator. Even if you do so, Vim can't toggle the cursor style on-the-fly. That's a limitation of the terminal itself.

If you are talking about the graphical version of vim, called gvim (or macvim), then look at Nupraptor answer.

BTW, I think this question is better suited to the Superuser.com site.

share|improve this answer
    
I found the option in iterm –  Derek Organ Jan 24 '11 at 2:52

If you're talking about gvim, then you can change the cursor to an 'I' when in insert mode with:

set guicursor=i:ver100-iCursor

EDIT: The 'i' is for insert mode. You can also define it for 'n', 'v', 'c' or 'a' (normal mode, visual mode, command mode or all modes, respectively).

share|improve this answer

This plugin for vim will actually change the cursor on the fly in iterm (and tmux)

It has a few bugs if you're in tmux, but works great outside of it: https://github.com/sjl/vitality.vim

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.