Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Hello im struggling for one week to get this to work without luck the problem seems strange though i set up openvpn on server and configure it then create license file for client and done the rest but when the client want to connect i got the following error :

TLS Error: TLS key negotiation failed to occur within 60 seconds

and now the strange part is if i connect my pptpd connection ( which runs on another server ) and then connect openvpn again i connect instantly without any problem or error

in my country im sure there is heavy firewall on all outgoing traffic but currently i do not understand what can cause this problem i ran tcpcump and seems server receive packets and send it back to client ( though im not sure if client can get the response ) this is my server.conf Code:

local myserver ip #Replace with your server IP address
port 443   #Replace with the desired port
proto udp #Choose between tcp and udp (remove instructions in bold)
dev tun
tun-mtu 1500
tun-mtu-extra 32
mssfix 1450
cipher AES-128-CBC
ca /etc/openvpn/keys/ca.crt
cert /etc/openvpn/keys/server.crt
key /etc/openvpn/keys/server.key
dh /etc/openvpn/keys/dh1024.pem
server 192.168.0.0 255.255.255.0
push "redirect-gateway def1"
push "dhcp-option DNS 213.133.99.98"
push "dhcp-option DNS 213.133.99.99"
keepalive 10 120
comp-lzo
persist-key
persist-tun
status server-vpn.log
verb 3

and os is centos 5.5 on openvz vps so any idea what can cause the problem ? regards

share|improve this question

2 Answers 2

Most probably your client is not getting packets back. That could be either routing issue or firewall.

You can test routing issues by running traceroute on server.

Testing firewall issues is harder, as there is no good way to trace which firewall blocks response packets. Of course you can run tcpdump (or wireshark) on your client machine to see whether packets are coming back.

share|improve this answer

try switching to 'tcp' mode (mode tcp); if there are heavy firewalls in place then this is most often the culprit.

I am not surprised that it works after a pptp connection - all traffic is (most likely) flowing over the pptp connection, which is not firewalled.

HTH,

JJK

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.