Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Scenario:

  1. LIVE Server: 210.210.210.210
  2. External IP of Office: 111.111.111.111
  3. SQL server on a server machine in office, machine name: MyMachine
  4. Another SQL server on another server machine in office, machine name: MyMachine2
  5. Name of instance on MYMachine: SQL2005
  6. Name of instance on MYMachine2: SQL2005
  7. Port on SQL Server on MyMachine: 1446
  8. Port on SQL Server on MyMachine2: 1443

I can successfully connect from live server to MyMachine2 using following credential

ServerName: 111.111.111.111
user: sa
pass: sa

But I am unable to connect on instance on MYMachine2 using following, using port.

ServerName: 111.111.111.111,1446
user: sa
pass: sa

Error:

TITLE: Connect to Server
------------------------------

Cannot connect to 111.111.111.111,1446

------------------------------
ADDITIONAL INFORMATION:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.) (Microsoft SQL Server, Error: 10060)
  1. TCP/IP port is enable on MyMachine
  2. Browser service is running

Any help?

All IPs and machine names are fake.

share|improve this question
    
Do you have a firewall running? Have you tried connecting on port 1433 in case your changes to 1446 have not taken effect? –  Sam Jan 24 '11 at 16:39
    
Yes, firewall is running but port 1446 is open in firewall. I can connect successfully using 1443 port on MyMachine2. –  Kashif Jan 24 '11 at 16:45
    
Are you specifying the instance name when you are connecting, i.e. 111.111.111.111\sql2005,1445? –  SqlACID Jan 24 '11 at 17:23
    
Are you sure that you're NAT'ing the public ip address to MyMachine for port 1446? Also, does MyMachine have a default gateway set? –  joeqwerty Jan 24 '11 at 17:37
    
@SqlACID thanks, yes I have tried using instance name but same problem. –  Kashif Jan 25 '11 at 6:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.