Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have very few experience in configuring servers and stuff, so I'am totally lost in this.

I tried to add php support to a nginx installation, but when a put this in nginx.conf.

location ~ \.php$ {
        root           html;
        fastcgi_pass   127.0.0.1:9000;
        fastcgi_index  index.php;
        fastcgi_param  SCRIPT_FILENAME  /scripts$fastcgi_script_name;
        include        fastcgi_params;
    }

and the I tried to restart, I have this error message

 [emerg]: unknown directive "fastcgi_pass" in /opt/nginx/conf/nginx.conf:67

Any clue?

Thanks in advance

PD:

nginx -V output nginx version: nginx/0.7.67 built by gcc 4.1.2 20080704 (Red Hat 4.1.2-48) --prefix=/opt/nginx --without-http_fastcgi_module --without-http_memcached_module --without-mail_pop3_module --without-mail_imap_module --without-mail_smtp_module --with-http_flv_module --add-module=../nginx_mod_h264_streaming-2.2.7 --without-http-cache

share|improve this question

migrated from stackoverflow.com Jan 24 '11 at 19:11

This question came from our site for professional and enthusiast programmers.

    
could you provide your full nginx.conf file and nginx version? –  imaximchuk Jan 24 '11 at 16:29
    
You need to recompile Nginx to include the fastcgi module. –  Martin Fjordvald Jan 24 '11 at 22:12

2 Answers 2

can you show nginx -V output?

it seems that nginx was built without fastcgi support (--without-http_fastcgi_module)

share|improve this answer

check this: "--without-http_fastcgi_module"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.