Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed Centos 5.5 on a headless server. The BIOS supports console redirection, so all I needed to do was: 1) Connect over a serial cable, 2) adjust the BIOS, 3) put the CD in, and 4) at the boot prompt, type:

linux console=ttyS0,115200n8    



On Ubuntu 10.10, I tried the same technique. Even before the boot: prompt, I received an error message:

graphics initialization failed
Error setting up gfxboot
boot:

and when I tried to the same command as on Centos, I received the error:

Could not find kernel image: linux


I then looked at the isolinux directory on the CD, and all the boot menus had something like /install/vmlinuz, so I tried:

/install/vmlinuz console=ttyS0,115200n8

But that fails with a kernel panic

[    3.271958] Kernel panic - not syncing: VFS: Unable to mount root fs on unknow
n-block(104,1)
[    3.280699] Pid: 1, comm: swapper Not tainted 2.6.35-22-generic #33-Ubuntu


Farther up the console output, I saw the error:

[    3.185400] VFS: Cannot open root device "(null)" or unknown-block(104,1)
[    3.192380] Please append a correct "root=" boot option; here are the availab
le partitions:

I'm going to keep trying, but I would welcome any advice on how to get Ubuntu 10.10 installed on my headless server.

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

Looking at the isolinux .cfg files, I came up with something to try:

/install/vmlinuz console=ttyS0,115200n8 file=/cdrom/preseed/ubuntu-server.seed initrd=/install/initrd.gz quiet --

It worked. I got a text based set of install menus.

I actually prefer seeing all the output when the system boots, so I also successfully used:

/install/vmlinuz console=ttyS0,115200n8 file=/cdrom/preseed/ubuntu-server.seed initrd=/install/initrd.gz

As an aside, if you need to run in rescue mode

/install/vmlinuz console=ttyS0,115200n8 initrd=/install/initrd.gz rescue/enable=true 
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.