Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a user here, our CEO, that can't keep his incoming email more than 3-4 minutes in his inbox. He is able to get the email, we see the popup confirming the email has been received but suddently, without warning, the emails go away!

I can find back the emails in "Tools - Recover Deleted Items" but they don't show in the Deleted items folder. But again, as soon I recover the emails, they disapear after few minutes again.

I'm running Echange 2007 SP1 on Windows Small Business Server 2008

What I've done to troubleshoot:

  • No Rules were/are setup in Outlook
  • Reinstall Office 2003
  • Reinstall Office 2007
  • Deleted/recreated the local profile
  • Deleted/recreated the AD profile
  • Deleted/recreated the Exchange 2007 account.

Even with a brand new Exchange mailbox, the email are still deleted in a few seconds after coming in the Inbox. He is the only one with that problem. The problem is also the same in OWA. So I'm pretty sure that issue is coming from Exchange or around that...

I'm not sure if a corrupted message could do this but I can't afford to neglect such details. Is anybody already fixed a problem like this one? Any help will be appreciated!!!

P.S. Sorry for my english and thank you!

share|improve this question
    
Your English is fine .. we all got it! –  tomjedrz Jun 9 '09 at 18:18
    
You accepted an answer. Can you satisfy our curiosity about what was happening? –  tomjedrz Jun 9 '09 at 18:18
1  
Thanks buddy! The issue was caused by Thunderbird. This mail client was not properly configured. The Exchange account has been setup in Thunderbird (I Allowed POP on my Exchange server) to receive email automatically each 10 minutes. So each 10 minutes, all email on the user account were picked up from the exchange server and being "deleted" from Outlook. I suck to haven't think about that earlier! Thanks a bunch everyone! David. –  user8740 Jun 9 '09 at 18:34

5 Answers 5

up vote 8 down vote accepted

Have you checked that he doesn't have a POP3 client set up somewhere that is connecting to the server, retrieving the e-mails, and deleting them?

Perhaps he has a mail client set up at home so he can get messages there too, and doesn't realize this will delete the messages off the server.

share|improve this answer
    
He mostly uses Thunderbird because is has a pop account on another server. Does it can affect the Outlook/Exchange? –  user8740 Jun 9 '09 at 15:23
    
Depends. If Thunderbird isn't set to leave the messages on the server after POP/IMAP'ing them, then you'd see the behavior exhibited. –  David Mackintosh Jun 9 '09 at 15:32
    
The default is to remove the message from the server (same as outlook, gmail and others' default pop settings). –  Rob Allen Jun 9 '09 at 15:53

The interval sounds like a external IMAP / POP client is checking in, getting the messages and then deleting them from the server. Is he using a smartphone, blackberry, email client at home that may be doing this?

share|improve this answer
    
Add gmail or other pop3 enabled fetchers. –  Sunny Jun 9 '09 at 15:25

Any chance his Auto-Archive settings are completely screwed up and running every few minutes?

share|improve this answer
    
I jsut took a look at the archive settings and everything is ok. There is no .pst file on his laptop (That I re-imaged on last week) Thanks John! –  user8740 Jun 9 '09 at 15:21

The other people have raised a very good point that emails may be fetched and deleted from the email client that uses POP3. I would say just easily turn off the pop3 feature on this user's account to see if the problem still occurs. Disabling POP3 won't effect his use of Outlook.

share|improve this answer

The most comon cause for this is the calendar settings. Check the automate processing in the mailbox.

Exchange 2007

get-mailboxcalendarsettings SMTP | fl

If automate processing is set to autoaccept change to autoupdate. Run this command to change.

set-mailboxcalendarsettings SMTP -automateprocessing $autoupdate

Exchange 2010

get-canlendarprocessing SMTP | fl

If automate processing is set to autoaccept change to autoupdate. Run this command to change.

set-calendarprocessing SMTP -automateprocessing $Autoupdate

This is the cause 90% of the time.

share|improve this answer
1  
How would the calendar settings result in email being removed from the inbox? –  Zoredache Feb 25 '12 at 1:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.