Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Last week, I began having trouble connecting to our internal web servers. Usually, a refresh would take care of it or switching to a different wireless network, but as of yesterday, this wasn't enough.

We have an internal DNS server using dnsmasq and a private internal host name (us.lcl). Once I started having more issues with the names not resolving, I tried pinging the server. Using the internal host name (, it failed. I tried using the IP address, but that also failed. I have no problems accessing external sites with the exception of it being a bit slower than normal. A reboot yesterday at lunch time after following the instructions here seemed to fix the issue, but when I came into the office this morning, it had stopped working.

As of this posting, I cannot ping, ssh or access the web server using the internal host name or ip address.

I'm the only one running 10.6 in my office and none of my colleagues has this issue.

share|improve this question

Please run the following from your 10.6 machine and verify the dns search-order to be the way you want it to be:

 scutil --dns

As of 10.6.3 the order of DNS servers has become dynamic, it might be that your problem is a result of that. See also:

share|improve this answer
The DNS servers are in the correct search order. The article you linked is the same one I linked in my description. – cabuki Jan 25 '11 at 16:06
Oops, sorry, missed the link :-) – Asmus Jan 26 '11 at 16:47

To eliminate a configuration issue on your wireless network try plugging into the ethernet network. Wireless networks if not configured properly will cause dramatic slow-downs when at higher loads (more connected stations) than when not utilized.

If it works fine from the wired network then there has to be some configuration issue on your wireless side. If it dosent work there may be a switch or router that is failing or some other mis-configuration in the network.

share|improve this answer
I've tried this too. I'm currently plugged into my wired network and it still doesn't work. I'm hesitant to think it's a misconfiguration in the network since I'm the only one experiencing the problem. Since I'm the only one in the office running OSX 10.6 (everyone else is on 10.5), I'm more inclined to believe the problem lies within Snow Leopard's recent update. – cabuki Jan 25 '11 at 16:10

Well, you're saying that:

Once I started having more issues with the names not resolving, I tried pinging the server. Using the internal host name (, it failed. I tried using the IP address, but that also failed.

it means that your problems are not based on DNS resolving. Is the server you're trying to reach on the same subnet? If no, are you able to ping any other device on the same subnet as is your computer?

share|improve this answer
Everything is on the same subnet and I can't ping or connect to any other computer on the subnet. I've tested things on 3 other Macs running 10.5 and all of them can connect to every other computer in the network. It's only my 10.6 machine that is having problems. – cabuki Jan 27 '11 at 8:43
So you are unable to ping other network devices while connected via wifi or ethernet cable? Try to connect any device using cable (you will need to use static IPs). This test will prove that networking on your 10.6 mac works at all (drivers, card etc). If it would work I mean the problem is in the network switch router. – BobC Jan 30 '11 at 7:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.