Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a CentOS box that hangs for like 8 hours at "Checking root filesystem" every time it reboots.

Is there some way to skip that check?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

When booting, edit the kernel line in grub and add 'fastboot' to the end (no quotes)- to do that, select the o/s to boot, hit 'e', and then 'e' again when the kernel line is being selected. Once edited hit escape to come back out of the editing mode and 'b' to boot. The changes are not saved for future boots.

In future, edit the /etc/fstab line and change the sixth field of the root partition to a 0 to avoid future fsck checks. That may not be a good idea so make sure you know what your doing.

You can also change how often the checks are done if that's more useful for you. For example:

sudo tune2fs -c 50 /dev/hda1

which will perform the check on hda1 every 50 boots (0 disables checks).

share|improve this answer
    
Thanks, that worked great! –  Keith Palmer Jan 25 '11 at 15:27

One of two things is happening:

  1. You only reboot occasionally, and the system thinks the disk has gone too long between checks, so is forcing one. There is an filesystem tuneable for this (interval-between-checks, in fact), and you can change it by running tune2fs -i 0 /dev/mapper/vg0-root (or whatever your proper root device is). There is also a max-mount-counts setting, which can be disabled with -c 0. (You can find the current values for these settings with dumpe2fs — don't worry about the scary name; it is, in fact, non-destructive.)
  2. Your filesystem is actually getting corrupted every time, and an fsck is necessary to put it back. If you are running ext2 (or ext3 without journaling!) this is what you'll get if you have an unclean shutdown (so, stop that). If you are using journaling and are still getting this every time and it is not because of the timeout option above, that's more concerning.

If #1 is the cause, you can skip it one time by creating /fastboot (with touch /fastboot as root) or by putting that on the kernel command line. However, if it's happening because of #2, that's not recommended.

Also, you may want to consider switching to ext4, which is fully-supported in RHEL 5.6 (and the any-day-now CentOS 5.6). The new version of the filesystem is designed to be much faster at fsck for large filesystems.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.