Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I build php 5.3.5 with FPM, but when I trien to started the php-fpm daemon this way :

sudo /usr/local/sbin/php-fpm start

nothing happens (the programs show me the help)

and when I did this

sudo /usr/local/sbin/php-fpm -t

 Jan 25 09:54:59.634168 [ALERT] [pool www] pm.min_spare_servers(0) must be a positive value 

Jan 25 09:54:59.634293 [ERROR] failed to post process the configuration

Any clue? I need to make this php work with nginx

share|improve this question

2 Answers 2

up vote 2 down vote accepted

What kind of help do you receive?

You should set pm.min_spare_servers to something like pm.min_spare_servers = 5 also check pm.max_spare_servers in php-fpm.conf

share|improve this answer
    
The program print the "usage" message –  Nisanio Jan 25 '11 at 18:45
    
you mean something like: Usage: php-fpm [ flags ] < options > Normal Options: start stop restart pause zap Default init.d options. ...? try to: 'sudo bash' then: '/usr/local/sbin/php-fpm start' what about '/usr/local/sbin/php-fpm -t'? now it doesn't complain about config options? –  Denis Kot Jan 26 '11 at 7:42

php-fpm does not take "start" "stop" arguments, it is not an init script. You kill it like this: "killall php-fpm" and you just start it like any simple script: /usr/local/sbin/php-fpm (without the "start" parameter)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.