Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

With software versions puppet-server 0.25.5 and puppet-dashboard 1.0.4, I have a fully functional puppet-dashboard instance complete with autoregistration of new check in reports. However, after enabling SSL on the vhost report auto-registration no longer occurs. I have verified that, from a user perspective the site otherwise functions correctly.

I have changed the PORT definition in my puppet_dashboard.rb file, and am not receiving any logs showing failed connections,etc.

Can anyone provide guidance on how best to debug, or fix this?

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

This is apparently less of an issue with setup and configuration, and more of an issue with design. The underlying report registration does not support SSL. Some more creative googling brought me to this Pastie post with the relevant code replicated below. Replace the process definition with the following in your puppet_dashboard.rb.

def process
  link = Net::HTTP.new(HOST, PORT)
  link.use_ssl = true
  link.verify_mode = OpenSSL::SSL::VERIFY_NONE
  link.start do |conn|
    conn.post "/reports", "report=" + CGI.escape(self.to_yaml)
  end
end
share|improve this answer
add comment

If you run dashboard under passenger you can add one more section in virtualhosts without SSL enabled in it and using that exclusively for reporting.

That also solves the similar problem with HTTPAuth enabled in web server for dashboard which also is not natively supported by dashboard.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.