Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an old Fedora 8 server running on instance store. I just built a Fedora 12 server that is on EBS. Now I know this may be redundant since my new Fedora 12 instance is on EBS, I would like for my web application to run on an EBS volume that I wish to mount to my new Fedora 12 instance.

I created a new 10 GB volume through Elasticfox. Then attached it to my Fedora 12 instance and set the device to be /dev/sdh.

Now when I SSH into my Fedora 12 instance, I run the following to partition this new volume:

mkfs.xfs /dev/sdh

And I get this error:

Cannot stat /dev/sda2: No such file or directory

Now if I do the exact same steps above on my old Fedora 8 instance on instance store, it all works fine.

My question is what am I doing wrong? Can I even attach a EBS volume to an instance that is already running on EBS?

I really appreciate the help.


share|improve this question

did you partitioned it by fdisk? user 'fdisk -l' to check all drives in the system. find your new drive then 'fdisk /dev/sdX' where 'X' is letter for your new drive. check this for info about partitioning:

share|improve this answer
I did not use fdisk. Not sure why I need to use that when mkfs worked in the past. But will certainly try at this point. THX! – AAC Jan 26 '11 at 18:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.