Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I can't seem to figure out how to enable the Windows Security Dialog when logging on to my server. It works for another server we have:

enter image description here

I know it was somewhere in the settings, but right now it connects directly to the server and gives a login screen like this: enter image description here

Anyone know why it does this and where I can change the settings to make the Windows Security Dialog pop up?

Thanks,
Matt

share|improve this question
    
I've often wondered this myself. Hope you find the answer! –  Nic Jan 26 '11 at 6:57

4 Answers 4

up vote 1 down vote accepted
+50

What you are seeing is a setting in Server 2008 that handles what type of encryption is used when the session is started.

To change it, go to Start -> Run -> tsconfig.msc, and double click on the RDP-Tcp connection. Select the Security layer that you want.

RDP Security Layer is the option in your second screenshot. This is required is you have users logging in and are required to change their passwords before logon.

Negotiate is the option in your first screen shot. As far as I'm aware, this is a default option for 2008 and 2008 R2 RDP servers.

Select the option you'd like, then log off and back on to see the change.

share|improve this answer
    
Any reason I should be using one or the other, other than what you've stated there about the RDP Security Layer? –  user29600 Feb 5 '11 at 5:12

That looks like every W2K8 remote session I've ever seen. Is the other server Windows Server 2003 by any chance?

share|improve this answer
    
Yes... is that the only reason they're different? I thought I had enabled the other one some how... –  user29600 Jan 25 '11 at 19:55
1  
If I'm not mistaken, yes. I've never seen the W2K3 style logon dialog box when connecting to W2K8. –  joeqwerty Jan 25 '11 at 20:36

I am also curious about exactly what causes the login screen to be presented instead of the security dialog. Although I can't answer your question, I can add my experience.

  • When I initiate a remote desktop connection from Windows Server 2003 to a computer running Windows Server 2008, AND I specify incorrect credentials (either in the dialog or saved in the .rdp file), then I will be presented with the Server 2008 login screen.
  • When initiate a remote desktop connection from Windows 7 to a computer running Windows Server 2003, I am always presented with the login screen.
  • All other tests always showed the security dialog then went straight to the logged in desktop.

While I was looking around, I saw many references to the local security policy option called "Interactive logon: Do not display last user name" which supposedly effects which login environment is shown, but I didn't see any difference when changing this value. YMMV.

share|improve this answer

Unless I'm reading the question wrong, I suspect the "Remember my settings" was ticked at some stage. Now you need to find out how to undo that so that it will prompt you again. Better yet, use GPO to have the servers always request a password.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.