Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've a subversion server, on Apache (on WindowsXP), which is accessible over the net using http. I wanted to use ssl/https to access it. I haven't messed around with forcing http -> https yet, and can login using http:// fine. However, if I use https://, the login fails, and I get an "Authentication required!" 401 error message.

I guess it's a configuration issue on my server(?), but haven't found a solution yet.

Any ideas?

edit I can connect and login via https://localhost ok, but not over the net via the ip address. I did put the ip address in when creating the certificate (via makecert).

snippet of conf file (I can add more if necessary):

httpd-ssl:

`VirtualHost _default_:443>
        #   General setup for the virtual host    t
        DocumentRoot "C:/xampp/htdocs"
        ServerName localhost:443
        ServerAdmin webmaster@localhost
        ErrorLog "logs/error.log"
        <IfModule log_config_module>
            CustomLog "logs/access.log" combined
        </IfModule>

        SSLEngine on

        SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
        #SSLCertificateFile "conf/ssl.crt/server-dsa.crt"
        SSLCertificateFile "conf/ssl.crt/server.crt"`

httpd.conf excerpt:

<IfModule ssl_module>
    SSLRandomSeed startup builtin
    SSLRandomSeed connect builtin
    SSLSessionCache "shmcb:logs/ssl.scache(512000)"
    SSLSessionCacheTimeout 300
</IfModule>

<Location /svn>
  DAV svn
  SVNListParentPath on
  SVNParentPath C:\SVN
  #SVNIndexXSLT "/svnindex.xsl"
  AuthType Basic
  AuthName "Subversion repositories"
  AuthUserFile passwd
  #AuthzSVNAccessFile svnaccessfile
  Require valid-user
</Location>
share|improve this question
    
Can you provide the apache virtual host configs for the http, and https sites? –  becomingwisest Jan 25 '11 at 18:58
    
Update: it's all working fine now, but I can't pinpoint exactly what caused it to work (which is a bit annoying, but anyway...). –  debs Jan 26 '11 at 18:28

1 Answer 1

Try adding this under ServerName:

ServerAlias 127.0.0.1:443
share|improve this answer
    
I just tried that (in the httpd-ssl.conf), but it hasn't worked. It's still getting past the warning message with the certificate not being trusted, but when I get to the subversion login, it fails that. It's still working fine on my local machine. –  debs Jan 25 '11 at 19:43
    
So everything is working the way you want it to when you go to "localhost", but not when you go to "127.0.0.1"? –  Travis Jan 25 '11 at 19:51
    
no, sorry, it's when I go to my actual ip address from an external pc. That still works fine via "http :// 82.xxx.xxx.xxx", but not "https :// 82.xxx.xxx.xxx". If I try the localhost etc. on the actual server machine, that works fine, after the cert. warning. (can't work out how to tag https, hence the spaces!) –  debs Jan 25 '11 at 19:55
    
all fixed now (see above). Thanks for your input. –  debs Jan 26 '11 at 18:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.