Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My situation

I recently installed Ubuntu 10.04 LTS Server on a virtual machine. I installed apache2, php and mysql. Several vhosts I sat up are running fine and I can also connect to the MySQL server using the mysql command-line client.

I now want to setup PhpMyAdmin to allow the vhosts owners to administrate their DBs. I installed the package using apt-get install phpmyadmin. I answered the questions and accepted the creation of the phpmyadmin database. The install finished successfully.

I did a small modification to the main website vhost to access it easily:

Alias /phpmyadmin /usr/share/phpmyadmin

I can now access the interface and login with my root user.

My problem

The problem is that on the bottom it says that I need to add a blowfish_secret to the server configuration. I've done it once in Fedora but here it's different. I tried to add it at the end of the /etc/phpmyadmin/ and to reload apache and clear the browser cache but it had absolutely no effect (the message is still here). I also noticed several other files :

  • /etc/phpmyadmin/config-db.php (apparently contains config needed to access the phpmyadmin database)
  • /var/lib/phpmyadmin/ (empty!?)
  • /var/lib/phpmyadmin/ (contains a correct blowfish_secret config line and was already there from the beginning)

I don't know where to do the blowfish configuration. Could someone explain in details or give a link about the configuration layout of phpmyadmin on Ubuntu 10.04 ?

I also have a second problem which is probably related. It says on the bottom that some features are disabled. I read somewhere that this line should be added:

$cfg['Servers'][$i]['tracking'] = 'pma_tracking';

but I don't know where to put it. Again, it has no effect when put in /etc/phpmyadmin/

I can provide the files if needed. Please just ask in a comment.

PS: The default installation works like a charm on my Ubuntu Desktop 10.10 laptop. No error messages and warning on the web interface.


share|improve this question
up vote 2 down vote accepted

Here's my honest opinion:

Uninstall PHPMyAdmin (I'm guessing you installed it via apt-get.

I've seen this happen and I pulled my hair out. What I recommend is, downloading PHPMyAdmin from their website and extract it to /etc/phpmyadmin. Then I'd change your Apache alias to

Alias /phpmyadmin /usr/share/phpmyadmin

From there, restart apache and you should be good.

One quick thing, you will need to edit the /etc/phpmyadmin/ file (which will need to be renamed upon installation, by the way - originally it is called You basically, will need to edit the $cfg['blowfish_secret'] = ''; section with random letters/numbers.

share|improve this answer
Thanks for your answer. You probably meant Alias "/phpmyadmin /etc/phpmyadmin". I would put it somewhere else like /opt/ though. I would prefer to use the one available in apt because it would be easier for the updates. I will do that if I can't find any other solution... – Marc Demierre Jan 26 '11 at 15:14
Ya, that's what I meant. Updates would be generally easier, but not that rough with a manual installation, as you would basically just overwrite the files (except the file). The one that comes with apt caused alot of issues on my end and I ended getting fed up with it. – drewrockshard Jan 26 '11 at 15:21
I've been trying to get this to work too on Ubuntu via apt-get which stores the blowfish_secret variable in a file called, however the does not reference it in any way and does not work if you reference it in PHP's include() or require() functions within the file. I have also tried to just place it within the file by adding the line $cfg['blowfish_secret'] = 'HashGoesHere'; and no go. What Drew says above with the manual install is probably the only solution. – ricbax Mar 6 '11 at 14:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.