Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have managed to install Apache2, Passenger and Ruby on Rails on a VPS machine with CentOS 5.5. To check everything is okay, I run in that machine links http://localhost, and the page is displayed correctly. This application is stored in /var/www/webapp.

However if I try to visit this page from outside. E.g.: http://212.227.XYZ.ZZ, I get the Apache welcome page located in /var/www/vhosts/default/htdocs/index.html.

This is part of my /etc/httpd/config/httpd.conf:

DocumentRoot "/var/www/"
LoadModule passenger_module /usr/local/lib/ruby/gems/1.9.1/gems/passenger-3.0.2/ext/apache2/mod_passenger.so
PassengerRoot /usr/local/lib/ruby/gems/1.9.1/gems/passenger-3.0.2
PassengerRuby /usr/local/bin/ruby

<VirtualHost *:80>
   ServerName 212.227.XYZ.ZZ
   DocumentRoot /var/www/webapp/public
   <Directory /var/www/webapp/public>
      AllowOverride all
      Options MultiViews
   </Directory>
</VirtualHost>

I have no idea why if I query the server from outside then I get different webpages. I have looked for config files in /etc/httpd/conf/ but I haven't found any other config file but httpd.conf.

I have tried as well to put this webapp in /var/www/vhosts/default/htdocs/, however I get the error: "Rails application failed to start properly".

How can I solve this problem? It's driving me crazy.

Thanks a lot.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Solved. I found the other config files which where overriding this behaviour. They are located in /etc/httpd/conf.d/.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.