Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I set up IIS 7 in Windows 7 and made a very simple script to test it in the Default website.

I get the the following error:

Parser Error Message: '”VB”' is not a supported language.
Source Error:
Line 1:  <%@ Page Language=”VB” %>

What am I doing wrong?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Did you copy the line from a web page or email which uses "curly" quotes?


If that's the case, replace them with normal quotes:

share|improve this answer
Mea culpa. You are correct. – mmcglynn Jan 27 '11 at 17:02

IIS uses VBScript as the default scripting language for Active Server Pages. There's a small but measurable performance degradation on pages where the scripting language is set explicitly, so unless you have a reason to change the scripting language for an individual page to something other than the default, you're much better off sticking to the default and omitting the @Language directive.

To change the scripting language in IIS, select a site or virtual directory to change, then choose Properties from the Action menu in the Internet Services Manager. Then, on the Directory tab (Home Directory, if you're configuring an entire site), click the Configuration button. In the resulting dialog box, click the App Options tab and change the default language.

share|improve this answer
I don't have a "Properties" selection in the "Actions" menu. I have Explore, Edit Permissions...,Edit Site, Bindings....,Basic Settings..., View Applications, View Virtual Directories. – mmcglynn Jan 26 '11 at 22:04
In the .NET Compilation section, I have "Default Language" set to "vb". Error still occurs. – mmcglynn Jan 26 '11 at 22:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.