Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've set up an experiment to test iscsitarget and initiator, which at some point worked. Later, I turned the setup back on and much to my dismay, the initiator machine stopped making block devices for its successful logins. As far as I know, I haven't changed anything on either machine.

Some details:

# iscsiadm -m node --login
Logging in to [iface: default, target: iqn.2010-12.nl.ytec.arbiter:arbiter.lun1, portal: 10.0.0.1,3260]
Logging in to [iface: default, target: iqn.2010-12.nl.ytec.arbiter:arbiter.lun2, portal: 10.0.0.1,3260]
Login to [iface: default, target: iqn.2010-12.nl.ytec.arbiter:arbiter.lun1, portal: 10.0.0.1,3260]: successful
Login to [iface: default, target: iqn.2010-12.nl.ytec.arbiter:arbiter.lun2, portal: 10.0.0.1,3260]: successful

Sessions:

# iscsiadm -m session
tcp: [3] 10.0.0.1:3260,1 iqn.2010-12.nl.ytec.arbiter:arbiter.lun1
tcp: [4] 10.0.0.1:3260,1 iqn.2010-12.nl.ytec.arbiter:arbiter.lun2

Netstat:

# netstat -n -p|grep 3260
tcp        0      0 10.0.0.2:48719          10.0.0.1:3260           ESTABLISHED 1078/iscsid     
tcp        0      0 10.0.0.2:48718          10.0.0.1:3260           ESTABLISHED 1078/iscsid

/var/log/syslog doesn't give errors:

Jan 27 11:41:49 vmnode001 kernel: [  378.041749] scsi7 : iSCSI Initiator over TCP/IP
Jan 27 11:41:49 vmnode001 kernel: [  378.044180] scsi8 : iSCSI Initiator over TCP/IP

lsscsi doesn't show my devices:

[0:0:1:0]    cd/dvd  TSSTcorp DVD-ROM TS-L333A D100  /dev/sr0
[4:0:0:0]    disk    ATA      Hitachi HUA72105 A74A  -       
[4:0:1:0]    disk    ATA      Hitachi HUA72105 A74A  -       
[4:1:0:0]    disk    Dell     VIRTUAL DISK     1028  /dev/sda

And there are no block devices in /dev for it:

# ls -1 /dev/sd*
/dev/sda
/dev/sda1
/dev/sda2
/dev/sda3
/dev/sda4

I tried loading all scsi kernel modules I could find, but that doesn't seem to be the problem.

I reall don't get this; it used to work. I found people with similar problems (here and here) but no solution.

Initiator is Debian Sqeeuze (testing), target is Debian Lenny (stable). iscsitarget is 0.4.16+svn162-3.1+lenny1, open-iscsi (initiator) is 2.0.871.3-2squeeze1. Target kernel: 2.6.26-2-amd64, initiator kernel: 2.6.32-5-amd64

share|improve this question

1 Answer 1

change name iqn.2010-12.nl.ytec.arbiter:arbiter.lun1 to iqn.2010-12.nl.ytec.arbiter:arbiter.blabla.lun1

share|improve this answer
    
It did work with that name, so I don't really know why that would fix it. However, I would try it, but I reinstalled the machine and gave it a different purpose :( –  Halfgaar Feb 28 '11 at 8:26
1  
Someone willing to elaborate on the reason for this :D? –  Vincenzo Pii Nov 25 '14 at 12:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.