Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

All my Windows 2008 server are giving me the same symptoms. When an XP client access their shares, and they upload a file, speed is good. When they download a file, speed is bad... very bad (around 5 times slower).

If the same client do the same test with the same file on W2K3 servers, we have no issues at all in both directions.

All the servers are in the same rack, on the same switch.

One more interesting fact, if I remote the server and do a file transfer from the server to the XP machine, I get no problem at all (up and down).

Transfer with netcps are fast and furious. I know it's something related to smb windows shares, but what!

Any idea?

share|improve this question

4 Answers 4

Try disabling SMB 2 on the server:

http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm

share|improve this answer
    
Already tried that but thanks, sorry for not mentioning. –  mickey Jan 27 '11 at 17:58

You might have to setup wireshark to analyse the SMB traffic between 2 machines. Once you put your finger on specific behaviour (excessive resets, etc...), you might get more traction in narrowing this down. Also, bring a Windows 7 laptop to work to make sure it isn't happening with that too.

Is there a difference with network switches between the 2k3 servers and the 2008 servers?

What's the difference between a local XP box and your remote XP box, other than the VPN software and the router? (i.e. bring your remote XP box to work and see if it does the same thing).

share|improve this answer
    
I already checked with WireShark, but I'm not a networking expert, I didn't see anything unusual. As far as using a Windows 7 machine, my work machine is a dual boot. And the problem occurs only in Win XP, not in Win 7. As for the switch, 2k3 servers and 2k8 are on the same switchs. It also happens on VMware 2k8 machines. –  mickey Jan 30 '11 at 14:19
    
Yes, I have since learned that there are many new network settings/services (some of them in hte network driver) that bugger up Windows Vista/7/2008 file sharing. Welcome to DRM (digital restrictions management)... –  DutchUncle Feb 6 '12 at 17:45

Check if the BIOS of your servers/clients has a "CPU C State" parameter (probably inside the "Power" category). If present, try setting that parameter to DISABLE.

share|improve this answer

Thinking about, this suggest a TCP Window scale issue (where there is probably a lot of acknowledgements from the receiver side). In this case, it is enabled by default on Window 2008 Where as it is not on Windows XP. So my suggestion would be to enable it on the XP client, which you can do so with this:

http://www.speedguide.net/articles/windows-2kxp-registry-tweaks-157

However, it is important to note that SMB 1.0 (Windows XP) is not optimized for WAN links, whereas SMB 2.0 (Windows Vista/7/2008) is. The best solution is to use Windows 7 as the client and only run XP when necessary in a VM.

share|improve this answer
    
That said, I really wish we had that Wireshark output. That would have helped us a lot in this case. –  Rilindo Dec 30 '11 at 15:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.