Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a long file path that works on my server, but a simliar path returns a 404 error when it is on my clients (IIS6) server (http://ddmat.com/).

Here's the functioning file path on my server: http://www.forgefx.com/projects/ddmat/install/Application Files/McCurdys_1_0_0_0/Content/FBX/CCAE1B33/Roof-sectionB-02.fbm/hello.htm

My guesses:

  1. Maybe the file path is too long?
  2. Maybe the ".fbm" in the directory path is invalid?

Sorry for the vauge problem description. Please let me know what additional info I can provide that'd be helpful.

Update: The problem happens even in short paths, with no spaces: http://www.myserver/test.folder/hell.htm

Thanks, Adam

share|improve this question

2 Answers 2

I'm interested in finding out the cause of this also. So I did some research online. I found this article. I think it might help answering this issue.

http://support.microsoft.com/kb/315122

share|improve this answer

The problem is the space in "Application Files". You should URL-encode the link (substitute the space with %20 in this case):

http://www.forgefx.com/projects/ddmat/install/Application%20Files/McCurdys_1_0_0_0/Content/FBX/CCAE1B33/Roof-sectionB-02.fbm/hello.htm

Update:

Two things:

  1. Perhaps your client forgot to install/enable static content on IIS. It's a feature that must be explicitly enabled on the server. See this blog post: Don't forget to check "Static content service" in IIS7 installation (it's Vista related: here the Windows Server 2008 procedure: http://www.trainsignaltraining.com/windows-server-2008-iis7 )

IIS check static content feature IIS 7

  1. It would be very strange, because it's not the default for .htm, but maybe your client's IIS/website configuration doesn't allow the htm mimetype. See this support article: IIS 6.0 does not serve unknown MIME types
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.