Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The Gentoo live-cd shows my drives as "hda", so I followed the Gentoo handbook and configured my partitions as "hda". However, the boot failed because, when booting into my kernel, it wanted to refer to the partitions as "sda".

So, I edited my fstab and grub's menu config file to refer to partitions as sda, and everything booted successfully.

Was this the right thing to do? Any other steps you would recommend regarding this? Is it surprising to you that a new minimal Gentoo livecd would refer to things as "hda" in the first place? And if so, do you suspect there may be some issues I need to resolve?

Thanks!

share|improve this question
add comment

4 Answers

That was the correct thing to do. The Gentoo LiveCD may have been using the IDE driver instead of the SCSI driver for your (I'm assuming) SATA hard drives. Slower, but guaranteed to be reliable. You shouldn't need to do anything else; your system is stable.

share|improve this answer
    
Ubuntu does this for an older computer I have with no SATA controller. All the hard drives are seen as sda. That is, of course, at install time as well as at boot time, so it didn't cause any problems. –  Joshua Nurczyk Jun 9 '09 at 18:37
add comment

Play with the SATA options in the BIOS - AFAIK "Combined" mode lets you access IDE or SATA (so different kernels can do different things... think it changed ~2.6.18) - try enhanced mode, and I think you'll get SDA all round, assuming the older kernel manages it ok, which it probably will.

Edit: FWIW, SmoothWall (where I work) found this on the UTM hardware we use - and there was a BIG difference in performance (hda was much slower)

Edit2: yes, I agree with previous poster - you did right. Check you are getting decent disk performance with:

hdparm -Tt /dev/sda

and if it is ok.. leave well alone :)

HTH,

Tom

share|improve this answer
add comment

For the record, and especially for lilo users, editing /etc/fstab and using

append="root=/dev/sda3"

in lilo.conf (don't touch root=/dev/hda3 though) works as well.

share|improve this answer
add comment

The proper way to fix this is to use UUIDs. Some more details are here. With a UUID it doesn't matter what the device name ends up as (hda, sda, sdc, etc), the system will find it.

For example my grub looks like

linux   /vmlinuz-2.6.32-21-generic root=UUID=ad915c21-080d-46aa-ae02-4c5ec69e026f ro   quiet splash

And my fstab

UUID=ad915c21-080d-46aa-ae02-4c5ec69e026f /               ext4    errors=remount-ro,relatime 0       1

If find my root drive's UUID by

# blkid /dev/sda7
/dev/sda7: UUID="ad915c21-080d-46aa-ae02-4c5ec69e026f" TYPE="ext4" 
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.