Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have the named script in init.d and a symbolic link in all of the rc#.d directories. I can manually run the script and the symbolic links and named will start just fine.

I added "touch /test.test" at the top of the script and the file is not created on startup, so I am thinking the script is never run. As far as I can tell there are no errors in any log anywhere.

Any ideas?

share|improve this question
    
chmod +x /path/to/your_script? Otherwise, how about filling in some details like OS? –  Chris S Jan 28 '11 at 4:24
    
Which Unix? It matters, for things like knobs to turn on. –  Phil P Jan 28 '11 at 4:33
    
I'm running the Amazon Linux AMI on EC2. –  Eric Milas Jan 28 '11 at 4:36
    
The script has execute permissions. –  Eric Milas Jan 28 '11 at 4:40

1 Answer 1

up vote 0 down vote accepted

Here's a hacky way to do it - call your startup script from /etc/rc.local, which gets executed last for every runlevel.

What does /sbin/chkconfig --list named report?

What does grep id.*initdefault /etc/inittab report? That tells you the init level that the machine is going in to by default, and you can crosscheck that with what chkconfig reports, to verify that your script is turned on for your default runlevel.

Check the /var/log/boot.log* files to see if your named script is getting called or not. Also examine //var/log/messages.

If you are booting to say runlevel 5, you could try calling sudo /sbin/init 3 from the command line to drop to level 3, hopefully you will see the list of shutdown/startup scripts that get run. Runlevel 3 still have network access so you can do that without losing your connection.

share|improve this answer
    
After running chkconfig --list named I noticed that named was OFF for all run levels so I ran chkconfig named on and everything worked. Thanks a bunch! –  Eric Milas Jan 28 '11 at 17:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.