Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've got an Amazon EC2 instance with the 64bit Linux AMI. I changed my shell to tcsh and then set up .tcshrc with

PATH = ".:/usr/local/lib/play-1.1:$PATH"

After a

$ source ~/.tcshrc
$ echo $PATH
/usr/local/lib/play-1.1:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin

I can't put anything into my path and have it get picked up for some reason.

I also tried an alias:

$ ln -s /usr/local/lib/play-1.1/play /usr/local/bin/play
$ play
play: command not found

with the same result, it doesn't get picked up in my path. Am I ignorant of some global config? My experience is with CentOS so this is strange to me.

/home/notbrain
notbrain@aws-dev1: echo $PATH
.:/usr/local/lib/play-1.1:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin

/home/notbrain
notbrain@aws-dev1: ls /usr/local/bin
total 8.0K
4.0K drwxr-xr-x  2 root 4.0K Jan 28 05:41 ./
4.0K drwxr-xr-x 13 root 4.0K Jan 11 21:44 ../
   0 lrwxrwxrwx  1 root   28 Jan 28 05:41 play -> /usr/local/lib/play-1.1/play*

/home/notbrain
notbrain@aws-dev1: play
play: Command not found.

/home/notbrain
notbrain@aws-dev1: sudo play
sudo: play: command not found

/home/notbrain
notbrain@aws-dev1: /usr/local/bin/play
~        _            _
~  _ __ | | __ _ _  _| |
~ | '_ \| |/ _' | || |_|
~ |  __/|_|\____|\__ (_)
~ |_|            |__/
~
~ play! 1.1, http://www.playframework.org
~
~ Usage: play cmd [app_path] [--options]
~
~ with,  new      Create a new application
~        run      Run the application in the current shell
~        help     Show play help
~

/home/notbrain
notbrain@aws-dev1:

Thanks,

Brian

share|improve this question

1 Answer 1

up vote 1 down vote accepted

For tcsh or csh:

set PATH = (. /usr/local/lib/play-1.1 $PATH) 
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.