Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed memcached and the memcache pecl extension. Now randomly I cannot get it to start. When I run service memcached start I get this:

Starting memcached: chown: `memcached\r': invalid user
 to switch toe user memcached
 [FAILED]

What is going on? As far as I know, I performed the installation correctly. In fact, it was running fine but must have randomly stopped...? Im running RedHat x86_64 es5.

EDIT: maybe I am doing this wrong. What command do I need to run to check if memcached is running?

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

first make sure you have the memcache user

id memcached

you have an error in your config.. looks like a dos line breaks.. Run the following command over the memcache sysconfig script

dos2unix /etc/sysconfig/memcached
share|improve this answer
    
This solved my problem, thank you! –  Petrus Jan 28 '11 at 16:44
    
dos2unix resolved my problem –  Spechal Dec 10 '12 at 22:41
add comment

How did you install memcached?

You should be able to run:

service memcached status

or

lsof -i :11211

or

ps -ef | grep memcache

to see if it's running.

Cheers

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.