Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a SQL server machine - It’s a VMWare image (running on ESXi hardware etc..) It has windows 2008 x64 standard The SQL install is SQL 2008 standard The virtual machine has 12gb of RAM, and 4 virtual CPU

The box is suffering from near 100% CPU a lot of the time I enabled the AWE- but SQL server only seems to use 3-4gb of RAM

Is there a way of making it use more available ram more effectively? cache results for example..?

share|improve this question
1  
Why are you messing with AWE? you have a 64-bit system? –  Chopper3 Jan 28 '11 at 18:56
    
Are you running SQL x86 or x64? You can verify this by running SELECT @@VERSION. The output for x64 should be: Microsoft SQL Server 2008 (SP2) - 10.0.4000.0 (X64) –  Greg Askew Jan 29 '11 at 17:15
    
What are the specs on the ESXi host, and how many other VMs are running on it (how many vCPUs)? Also, what are the min and max memory settings set to on the SQL server? –  Paul Kroon Jan 31 '11 at 1:16
    
Microsoft SQL Server 2008 R2 (RTM) - 10.50.1600.1 (X64) Apr 2 2010 15:48:46 Copyright (c) Microsoft Corporation Standard Edition (64-bit) on Windows NT 6.1 <X64> (Build 7600: ) (VM) –  alex Feb 3 '11 at 17:02

1 Answer 1

up vote 2 down vote accepted

My limited understanding of VMware is that allocating more then one vCPU imposes a performance hit as the host needs to wait until an available slice is available on all CPU's. I could be dead wrong but as a test I would shut it down, reconfigure it with a single vCPU and see what happens.

EDIT:

In addition, indiscriminatley throwing RAM at what appears to be a CPU problem is not exactly the best approach. Some monitoring with perfmon is probably needed to track down the root cause of the CPU performance problem. It sounds like you're trying to correlate the high CPU utilization to SQL's "lack" of memory consumption, which is an erroneous conclusion to draw.

"Hmm... SQL Server is only using 4GB of RAM, that must be why the CPU is 100% utilized" is not a jump I would make without confirming it with some very in depth perfmon statistics.

share|improve this answer
    
You're not dead wrong JoeQ but more recent releases significantly reduce this 'cpu ready' issue - of course we don't know what version the OP has so it's still valid - just wanted you to know. –  Chopper3 Jan 28 '11 at 18:55
    
Thanks for the info Chopper. –  joeqwerty Jan 28 '11 at 20:15
    
Hi, thanks for your comments. The VM is hosted on vSphere4 Also, only one of the vCPU is at 100% - the others are fine... –  alex Feb 1 '11 at 16:13
    
Have you tried reconfiguring it with only 1 vCPU? I'm curious as to whether that has any bearing on the problem. –  joeqwerty Feb 1 '11 at 18:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.