Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do I correctly configure "www" for my website?

I'm running a DNS test suite and receiving the following error message for www.wordswithfriends.net

Received: HTTP/1.1 301 Moved Permanently (Server: Apache) Location: http://wordswithfriends.net/ Your main page redirects to another location. Several search engines will be unable to index your site.

This is not done in .htaccess at the moment as far as I can tell. How can I change it so that www.wordswithfriends.net does not redirect. I have full admin rights. Currently I have both addresses pointing to the same IP.

share|improve this question

2 Answers 2

It looks like you are running WordPress, and you probably configured your site name to be just wordswithfriends.net. In order to use www.wordswithfriends.net, head into the Wordpress Admin pages and go to Settings => General. Prefix both "Wordpress Address" and "Site Address" with www., and your site should stop redirecting...

share|improve this answer

Assuming that Apache is listen based on IP drop the Cname and setup another A record for www. pointing to the same IP as example.com.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.