Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I got a new server but unfortunately the hoster only installs me Ubuntu 8.04 in german.

So the upgrade worked smoothly, but now I am trying to change the system to english.

I adapted /etc/environment


And after searching forums I installed update-locale which generated the file /etc/default/locale


(this is the file i commonly remember from debian systems to hold the locale)

then i did dpkg-reconfigure locales which configured all the locales and after log out and relogin almost everything was in english.


the welcome messages is. the programs come in english. but for example apt is not:

prag341:~# apt-get upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut       
Status-Informationen einlesen... Fertig
Die folgenden Pakete werden aktualisiert:
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 4,346B an Archiven heruntergeladen werden.
Nach dieser Operation werden 0B Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]? 

which is a very bad thing because then the default arguments Y/N become exchanged by J/N etc.

How can i correctly change the locale to default us english in uft8 as if i had installed it from the beginnig?

share|improve this question
Have a look at this link: – Khaled Jan 29 '11 at 12:03
thats what i already looked like. one file did not exist in the first place and was added be update-locale. i configured both accordintly – The Shurrican Jan 29 '11 at 12:13
here is an examle how to install or reinstall locale – Володимир Вонс Oct 21 at 6:03

2 Answers 2

up vote 6 down vote accepted

You're very close! You just need to change your preferred language list

From this


To this


Once this is done reboot your server and all the system languages should be in English

share|improve this answer
thanks! it worked. but can you explain why? i just re arranged them and put en_us in the front. why did that not work?? – The Shurrican Jan 29 '11 at 13:56
No need to reboot, you can do export LANGUAGE="en_US" in the command line or just source /etc/profile right? May not be applied for all programs but apt-get was in English after I did that – Sam Stoelinga Jun 15 '12 at 6:49

But first you need to have needed language pack installed. On my German based VPS there was no english language pack pre-installed. So first you check that you have it installed:

aptitude install language-pack-en
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.