Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Please excuse my ultra newbie questions. I have a problem with two RAID 0 hard drives from a WD My Book which has failed. The drives have the ext3 file system and are Linux raid autodetect type. Here are the questions: Does the mkdir /media/testing approach create the directories on the boot drive? Is that approach going to work for me since I have two physical drives?

share|improve this question

3 Answers 3

The MyBook is just a Linux appliance. In the MyBook NAS with a single disk it's simply a broken RAID mirror, as it is missing the second disk but is already configured.

You can run mount to see the currently mounted filesystems. cat /proc/mdstat will show the status of the RAID.

What are you attempting to do? Further information is necessary to provide you a more concise answer.

share|improve this answer
First, thank you very much for helping. The (broken) MyBook had two 1 TB drives in a raid 0 configuration. It was used as NAS and had a whole bunch of really important files on it. I'm trying to attach the drives to a UBUNTU 10.10 box, recreate the RAID, mount the RAID, and get the files back. Two things, if there is a better LINUX dist, I can change the hard drives and install a new OS. Second, if there is a way to capture screen shots, I'll post them. – user68697 Jan 29 '11 at 23:03
If you had a disk in a RAID0 fail with no backups, your data is probably toast without paying a data recovery service. I lost my notes for re-assembly so I will have to re-write from scratch. I'll give more details later but mdadm --assemble --scan should work in many cases. – Warner Jan 31 '11 at 22:12
Warner, thanks a bunch for the help. When I run the UBUNTU 10.10 Disk Utility I get a green dot and a "disk is healthy" message on the S.M.A.R.T. satus line for each drive. I dropped to a Terminal window and did the mdadm command you gave me and I got no response (and no error message) which I assume is good. Not knowing what else to do, I returned to the UBUNTU Disk Utility and tried to mount the volume. I got an error message of "error mounting: mount: wrong fs type, bad option, bad superblock on /dev/md4, missing codepage or helper program, none of which sounds good. – user68697 Feb 1 '11 at 3:35
What does cat /proc/mdstat show after you assemble? – Warner Feb 1 '11 at 15:12
personalities : [raid1] [raid0] [linear] [multipath] [raid6] [raid5] [raid4] [raid10] md4 : active raid0 sdc4[0] sdb4[1] 1945407104 blocks 64k chunks md2 : active raid1 sdb2[1] sdc2[0] 104320 blocks [2/2] [uu] md1 : active raid1 sdc1[0] sdb1[1] 2939776 blocks [2/2] [uu] md3 : active raid1 sdc3[0] sdb3[1] 987904 blocks [2/2] [uu] unused devices: <none> looks like the data is on md4?? thanks again – user68697 Feb 1 '11 at 23:35

Is that approach going to work for me since I have two physical drives?

No, because data splits across two disks.

I test on MyBook Studio Edition 1TB, but RAID not failed:

# mknod /dev/md4 b 9 4
# mdadm -Cv /dev/md4 -l0 -n2 -c64 /dev/sdb4 /dev/sdc4
# mkdir /media/mybook
# mount /dev/md4 /media/mybook
share|improve this answer
First, thank you for the help. When I went to the WIKI link, the first command was mdprobe md. That came back with a Fatal: Module md not found error. I'm currently using UBUNTU 10.10 but can install something else if need be. Thanks. – user68697 Jan 29 '11 at 23:19

I would initially try mdadm --build ... to test-build the array with params being tested, then mdadm -o to make it read-only, then checking mounting read-only and possibly fsck. Only since the 2 last steps (as well as own files checking) would complete relatively successfully, I would re-create the array with the same params as used when '--build'ing. Otherwise data loss chances would be too high.

share|improve this answer
I would be glad to do those steps but I'm too much of a Linux newbie to know how. Can you give me simpler language? I got the mdadm --build part but I don't know what params to use. Thanks.. – user68697 Feb 1 '11 at 23:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.