Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
    -> TO 'repl'@'localhost' IDENTIFIED BY 'password123';

mysql -u repl -p'password123'

Access denied for user 'repl'@'localhost' (using password: YES)

Is a mysql user with replication privilege only, not allowed to login?

I've tried resetting the password, I get the same result.

share|improve this question
Did you execute the flush privileges command on mysql prompt after granting the permissions? – Khaled Jan 30 '11 at 8:58
Yes, actually, I'm already running replication using that user. – gAMBOOKa Jan 30 '11 at 9:00
The replication user should be allowed to login as any other user. I can notice that repl is created on localhost. Usually, you should create it on other_ip_host. Is this for testing only? – Khaled Jan 30 '11 at 9:18
You're right Khaled, that was it. Sorry for the misinformation. I was trying to simplify things. – gAMBOOKa Jan 30 '11 at 10:13
up vote 0 down vote accepted

As Khaled mentioned in the comments, replication users are generally created on the remote server. I was creating it like this, the question is incorrect:

-> TO 'repl'@'remoteip' IDENTIFIED BY 'password123';

So if you have issues logging in as a replication user, make sure you're logging in from the remote server.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.