Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

so I have 2 external drives on a ubuntu computer, and the mount point in fstab is in my home directory. however, I seems to only be writable by root. heres the relevent fstab lines:

/dev/sdb1  /home/henry/usb3hdd0  ext4  user,nosuid,uhelper=udisks,noexec,nodev  0       2
/dev/sdc1  /home/henry/usb2hdd1  ext4  user,nosuid,uhelper=udisks,noexec,nodev  0       2
share|improve this question
add comment

1 Answer

Use chown -R /home/henry/usb3hdd0 /home/henry/usb2/hdd1 to give you access to all the files on the disk. Ownership will follow wherever you mount the disk. Default owner for the root directory of a disk. You need to change it to allow you access.

I was thinking windows partitions in which case you would have various options.

  • Add noauto to the options, and mount it yourself. I believe this will give you access.
  • Add user=henry to the options. This will give you access to disks.
  • Add the appropriate mode option to enable access.
share|improve this answer
    
thanks, that worked. –  hintss Jan 30 '11 at 20:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.