Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

With a recent package and kernel update truecrypt refuses to unmount drives with

device-mapper: remove ioctl failed: Device or resource busy Command failed

(worked fine before) Ubuntu 10.10
I use the lastest version 7.0a of truecrypt and even build the binary but without change.

Any ideas ?
Thanks
Sven

share|improve this question
    
Hi, I did what the 1st answer( By John) asked to do. But still the problem is not solved.Still I can't unmount the mounted TrueCrypt volum. I'm using TrueCrypt 7.0a in Ubuntu 10.10. It was working fine until I install the recent updates of Ubuntu. Please help me. –  user72199 Feb 25 '11 at 14:31
    
I usually get that error if something is accessing the drive. i.e transmission-bt is running. Any chance the update started something that's accessing your drive? –  Brian Feb 25 '11 at 15:30

2 Answers 2

up vote 1 down vote accepted

To fix this, do the following in the TrueCrypt GUI in Ubunto:

Go to Setting > Preferences > System Integration > Kernel Services and check the box "Do not use kernel cryptographic services"

share|improve this answer

As a workaround, you can unmount from command line:

sudo umount /media/truecrypt8

Then dismount it from TrueCrypt GUI.

share|improve this answer

protected by sysadmin1138 Mar 4 '11 at 22:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.