Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I ran /scripts/easyapache on one of my cpanel servers last night and since then PHP just gives 501 errors, which no logs I can find. I tried running it again and it's running as normal but all output has been replaced with strange characters, eg:

␌␤␊␌┐␋┼± °⎺⎼ ⎻┬␍.␤... ≤␊⎽
␌␤␊␌┐␋┼± °⎺⎼ ┤├␋└␊.␤... ≤␊⎽
␌␤␊␌┐␋┼± °⎺⎼ ⎽≤⎽/┤├␋└␊.␤... ┼⎺
␌␤␊␌┐␋┼± °⎺⎼ ⎽≤⎽/⎻⎺┌┌.␤... ≤␊⎽
␌␤␊␌┐␋┼± °⎺⎼ ⎻⎺┌┌.␤... ≤␊⎽
␌␤␊␌┐␋┼± °⎺⎼ ⎽⎺␌┐␊├.␤... ┼⎺
␌␤␊␌┐␋┼± °⎺⎼ ⎽≤⎽/⎼␊⎽⎺┤⎼␌␊.␤... ≤␊⎽
␌␤␊␌┐␋┼± °⎺⎼ ┌␋␉±␊┼.␤... ≤␊⎽
␌␤␊␌┐␋┼± °⎺⎼ ┌⎺␌▒┌␊.␤... ≤␊⎽

Has anyone come across this before? Is it fixable?

share|improve this question
    
Closing this myself as I've fixed it without determining the original problem. Thanks for the help anyway. –  James Lawrie Jan 31 '11 at 7:19

2 Answers 2

up vote 0 down vote accepted

Can you please provide:

  • OS you are using
  • Version of CPanel
  • What you changed before doing a recompile?
  • Do you have the log of the build you did? I think it can be found in /usr/local/cpanel/logs/easy/apache/

Have you successfully used easyapache on this machine before? Try reverting what ever change you made and rebuilding.

share|improve this answer

Log out and log back in. I think your terminal is hosed from the application sending binary data. That is why you are seeing those characters.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.