Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Hiding a user by checking the "hide from exchange address lists" from exchange management console is not working. The user still shows up in GAL.

When I ran Get-Mailbox -Identity _user_ | FL I got HiddenFromAddressListsEnabled : True

So the check-box is working but the user still shows up. It's been over 3 weeks since hiding the user so it's not a time issue.

This is what I have tried:

  • Using Outlook in online mode
  • Using OWA
  • Regenerating GAL
  • Un-checking then re-checking the "hide" check-box
share|improve this question

2 Answers 2

This sounds like it might be a permissions issue on the Active Directory attributes of this user. I suspect the user is currently in (or was once in) one of the Active Directory protected groups (listed here).

You have 2 options depending on what situation you are trying to hide the user.

  • If this is a user who has left, remove the user from the protected groups and enable inheritable permissions on the user object.
  • If this is an account which still requires admin permissions, you can enable inheritable permissions and immediately rebuild the offline address book. The inheritable permissions flag is reset once an hour, so provided you rebuild your OAB before it is reset, you should be fine.

To enable inheritable permissions on the user object, follow this procedure.

  • In Active Directory Users and Computers on the View menu, click Advanced Features
  • Go to the properties of the affected user object, go to the Security tab and hit the Advanced button
  • Check the box labelled Allow inheritable permissions from parent to propagate to this object and all child objects
share|improve this answer
    
Actually, no, he is not. I checked some other "hidden users" and they're showing up in GAL as well. –  Abdullah Feb 1 '11 at 11:06

My experience is with Exchange 2010 and Outlook 2007:

We use vbScript to set the "msExchHideFromAddressLists" value to TRUE. In the Exchange Management Console we see the check mark next to 'Hide from Exchange address lists'. However, when we check in our Outlook 2007 client, the user's email is NOT hidden (even after giving it time to replicate to other DCs.)

Our work-a-round is not automated. For each user in our log file that has been automatically set "msExchHideFromAddressLists" to TRUE, we manually go into our Exchange Management Console, and uncheck "Hide from Exchange address lists" press Apply, then check again "Hide from Exchange address lists" and click Apply/OK. When using the GUI it behaves differently than simply using the backdoor vbScript to set msExchHideFromAddressLists to TRUE and we have not solved what additional processing the GUI performs.

share|improve this answer
2  
Why in the world are you using VBScript with Exchange 2010?!? What has PowerShell done to you? –  Massimo May 27 at 15:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.