Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On a Windows domain controlled by Samba, some of the Windows XP clients have begun to synchronise something automatically on logout. After any user has logged off, some program attempts to synchronize files. These do not succeed as each user would have to enter her password.

It is difficult to find any information about this "Synchronisation Manager". How would I disable it completely?

Another symptom is that the programs Synchronization Manager and Connections Tray must be force-closed on logout.

Kind regards

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You're seeing the default behavior of "Offline Files" in Windows XP for a domain-joined PC.

In an Active Directory environment I'd just use Group Policy to disable this feature on computers where I didn't want it enabled. You can't use Group Policy because you don't have Active Directory. You can create an old-style NTCONFIG.POL configuration file, stored in the netlogon directory of your domain, that will turn off Offline Files, but you can't apply that granularly (like, for example, leaving it enabled on laptop computers but disabling it on desktop computers). Microsoft has some guidance on doing this on their site. You'll find that some Samba-related mailing lists discuss Offline Files and disabling it, too.

A couple of other ways to disable it:

  • Edit the "Local Group Policy" on each machine using gpedit.msc. Navigate to "Computer Configuration", "Administrative Templates", "Network", and "Offline Files" and disable the setting "Allow or Disallow the use of the Offline Files feature".

  • Deploy a logon script, assuming your users have Administrator rights (which they really shouldn't have), to set the registry setting to disable Offline Files. The setting is a REG_DWORD value named "Enabled" in "HKLM\Software\Policies\Microsoft\Windows\NetCache".

share|improve this answer
    
Thank you very much! The relevant registry entry for my situation seemed to be CSCEnabled in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MRxSmb\Parameters. –  user68912 Jan 31 '11 at 19:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.