Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My home-backup server, with 8*2TB disks won't boot anymore. Two disks failed at the same time and i rebuilt the raid 6 array with no problem, but now i can't boot the os. I'm using ubuntu server, 10.10.

I've made screens of the displays to don't copy everything here.

The problem at the boot: http://img7.imageshack.us/img7/2360/dsc0407nl.jpg

And the Grub config: http:// img6.imageshack.us/img6/2789/dsc0408ni.jpg

If anyone can try to help, it would be great. It's not a production server, but i would like to have it online. I've tried for the lasts 2 days (just a couple hours a day) but without success.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

The problem lies with your fstab. When you created the new raid array, it ended up with a new UUID which is what you are using to specify your root filesystem.

It looks like you can get to busybox (the emergency shell), so mount up your root filesystem manually, edit /etc/fstab, and put in the correct UUID (you can get it with blkid /dev/sdX1 or the output from your mdadm output in your screenshot)

Notes: You will need to remount root as read/write to edit fstab. If you are unfamiliar with the process, its mount -o remount,rw /

share|improve this answer
    
I've tried mount -o remount,rw / but it outputs nothing. Also, /etc/fstab is still not found. I've than tried mkdIr /test/ and mount /dev/md1 /test, but it says that Ive invalid argument. Sorry for being dummy! –  cedivad Jan 31 '11 at 19:09
    
Also, I don't get the sense. /etc/fstab is inside the mdadm array, the one that dosent load. I think that I should than edit something outside the array to let the system load the array! Or no? –  cedivad Jan 31 '11 at 19:35
    
The mount command shouldnt output anything, thats a good sign. After that you need to edit /etc/fstab. I dont know the particulars of your setup, but if youre using an initrd, the initrd might be auto-assembling the array, and then once the its assembled it tries to read the /etc/fstab and this fails. However this is all general linux info. If you dont get a good answer here, you might try ubuntu's forums. –  Patrick Feb 1 '11 at 6:02
    
Thank you Patrick for your support, I will try the ubuntu forum =) thank you again, it's mostly my fault of being a dumb ;) –  cedivad Feb 1 '11 at 6:25
add comment

IT would be a good idea to boot from an Ubuntu liveCD and see if you can mount the partitions on the RADI6 array that way. This way you can then edit your grub and fstab configuration easily (i.e. you don't have to use vi and you can have manual pages or tutorials open :-) )

Also, you need to carefully think about why 2 hard disks failed at once. There could be many more failures already waiting to happen very soon.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.