Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows SBS 2003 SP2 DC that is severely messed up. This system has 55 users and they are all using redirected "home" folders to "e:\Users Shared Folders" I need to backup the files in each users folder, but I constantly get "Access Denied" error messages with Domain Administrators.

I followed Microsoft's guide on trying Moving data folders needless to say that fails at trying to change the permissions on the user folders.

Example: e:\Users Shared Folders\dianad is no longer needed so it is safe to remove, I went into the inheritance of all the sub folders under e:\Users Shared Folders and pushed it(inheritance) because this is going to have to happen to them all anyway.

I set the share access to everyone and NTFS permissions to administrator group FULL on ~\dianad\ and removed inheritance for this folder only, now when trying to remove this folder I can remove all the folders except desktop and mydocs. So I figured that's weird I know I set all the permissions as loose as possible on this test case, so I went to the command line and used cacls, Below is the output:

E:\>cacls "e:\Users Shared Folders\DianaD" /T /G "Administrators":F /Y
processed dir: e:\Users Shared Folders\DianaD
Access is denied.

Here is the output from cacls query on the folder

E:\>cacls "e:\Users Shared Folders\DianaD"
e:\Users Shared Folders\DianaD BUILTIN\Administrators:(OI)(CI)F

Now I have been trying everything I can to reset the permissions on this and nothing has worked. I have searched around the net and found some similar issues but nothing ever gets resolved.

I am hoping someone here has run into this and can point me in the right direction.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I have found that the following ritual works when resetting permissions on a folder and its subfolders (Win2003 and earlier):

  1. View the folder's Security tab.
  2. If possible, add the local Administrators group and give it full control.
  3. Click Advanced and go to the Owner tab.
  4. Highlight the local Administrators group.
  5. Put a check in the box for "Replace owner on subcontainers" etc.
  6. Click Apply.
  7. Go to the Permissions tab.
  8. Put a check in the box for "Replace permission entries on all child objects" etc.
  9. Click OK.

At this point you should have complete access to the folder and its contents. Manipulate the permissions to your heart's content.

share|improve this answer
    
Thanks @Craig Putname the Replace permissions on all children was the missing link. –  Dan M. Feb 1 '11 at 14:58

It is probably an ownership issue. Reset the owner status then try resetting the permissions.

share|improve this answer
    
I did that already with no change in the results. –  Dan M. Jan 31 '11 at 22:25
    
I've had an issue like this before, it was on a system with a single drive, I took the drive out of the system and moved it to another 2003 server and reset the security permissions for the offending folder and then put it back in the original box and was able to edit everything there like normal. –  ErnieTheGeek Jan 31 '11 at 22:35
    
I wish that was an option, but this is the entire users redirected share so in essence all users have the same problem. –  Dan M. Feb 1 '11 at 0:39
    
Added +1, it helped :) –  Dan M. Feb 1 '11 at 13:46
    
Glad it helped! So what was the final resolution? –  ErnieTheGeek Feb 1 '11 at 14:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.