Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm using Aws AIM. So, how to install openSSL? I have no idea how to do it.

It is because I want to compile node.js with ssl so that I can have crypto support.

I tried pkg-config..etc from here: Node.js installation: openssl not installed

however, apt-get doesn't exist. pkg-config doesn't recognize the -lssl

I totally have no idea..

share|improve this question

1 Answer 1

The "Official" Amazon Linux Images are based off a CentOS image, so you want to use yum as your package manager, not apt-get.

share|improve this answer
    
there are a ton of community ami's that are based of ubuntu also –  Mike Feb 2 '11 at 16:31
    
thanks. i got it working now. .thanks. basically, I need to install openssl_devl , the development tool. :) –  seatoskyhk Feb 2 '11 at 17:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.