Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Exchange 2010 and 2003 in coexistence, and recently switched to using Exchange 2010 as my OWA server. User mailboxes are still on 2003.

Almost everything works fine, except that when users click the "Log Off" button in OWA 2003, they get a 404 error. Exchange 2010 OWA users have no problem logging off.

Exch 10 CAS: mail.company.com (This is an NLB, if it matters). Exch 2003 Front End: legacy.company.com

Outlook Web Access/App works fine for both 2003 and 2010 users. Users can successfully login and view their mailboxes on the legacy 2003 side through the 2010 CAS. I don't have any certificate errors.

The mail URL refers to Exchange 2010, which uses a Virtual Directory to /owa for /exchweb. There is no /bin/auth/owalogon.asp file in the Exchange 2010 directory structure. That file/directory structure DOES exist on the 2003 side, but the log off button redirects to mail, not to legacy I tried copying the 2003 /bin/auth directory over to 2010, but that didn't work.

Has anyone seen this behavior? Are your OWA 2003 log off URLs different? Any idea if I can customize the logoff command in Exchange 2003 to forward to a working log off page? Any other ideas on how to address the issue? My searches have turned up nothing.

share|improve this question
    
Have you made any changes to the virtual directories on your '03 installation? Particularly in the areas of redirection... Have you set the -exchange2003url option when you run the set-owavirtualdirectory command? I've never seen this behavior before, our logoff for 2003 worked properly out of the box, following microsoft's install procedures. –  Tatas Feb 11 '11 at 22:25
    
I think some changes were made to the Outlook 2003 installation, but I'm not sure which ones or when. I don't have a vanilla 2003 install to compare it to. It worked fine when it was all 2003. I did set the -exchange2003url properly. Thanks for the response. –  Carl Campos Feb 17 '11 at 21:33

1 Answer 1

Since there are no answers for this I thought I would provide you with a hack that could fix this.

On your OWA front end servers set your 404 page to redirect back to the login screen.

Here is an article on how to do this in II7.

http://technet.microsoft.com/en-us/library/cc771076%28WS.10%29.aspx

Hopefully this will tide things over until you can completely remove 2003 from your organization. Obviously redirecting any 404 to the login page is not ideal.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.