Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So Samba4 has worked for the past 5 months with my current setup; however, today I attempted to connect to my share and I received this error:

\\{server} is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

The specified domain either does not exist or could not be contacted.

Here is my smb.conf.

I have already tried restarting samba and restarting the server. I also found an error in the log.smbd. Which simply said that the port was already being used so smbd couldn't be started, I think that is b/c an instance of smbd is already running, which should be a problem.

share|improve this question
Do you have log file entries for this connection attempt? – Sven Feb 1 '11 at 1:19
If you stop samba, and you run ps, do any samba services still run? – becomingwisest Feb 1 '11 at 1:36
I have since decided to just reinstall according to the samba wiki, because it came to my attention that I installed it improperly. Probably not the reason it no longer works, but hopefully it will fix itself when I reinstall. – JayD3e Feb 1 '11 at 2:40

It looks like the problem might be in how the samba services are started on your server. Pay close attention to any Samba README's or tutorials that are specific to your distro.

share|improve this answer
Yah the problem ended up being that I was running samba 3.5.6 as well as samba 4. I didn't realize that Samba 4 is in alpha, and it got installed for some reason. – JayD3e Feb 2 '11 at 2:32
Ouch. You need to keep better notes/documentation about what is running where, and what revision it is :-) – DutchUncle Feb 2 '11 at 10:18

You might try seeing what is bound to those ports using the venerable lsof command:

lsof -i :445

lsof -i :137

lsof -i :138

lsof -i :139

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.