Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The parameter can be seen here

http://wordswithfriends.net/test.php

open_basedir    /var/www/vhosts/wor.wordswithfriends.net/wordswithfriends.net/:/tmp

I'm trying to add PHP pear directories

/var/www/vhosts/wor.wordswithfriends.net/conf is as follows

-rw-r-----  1 root apache   6461 Jan 25 08:56 12959674170.16899500_httpd.include
-rw-r-----  1 root apache   6461 Jan 31 06:52 12960111810.31860800_httpd.include
-rw-r-----  1 root apache   6532 Jan 31 06:55 12964785250.54523600_httpd.include
-rw-r-----  1 root apache   6532 Jan 31 07:01 12964788880.47252600_httpd.include
-rw-r-----  1 root apache   6532 Jan 31 15:54 12965108850.92819600_httpd.include
-rw-r-----  1 root apache   6652 Jan 31 21:32 12965206700.32285200_httpd.include

Currently configured as follows

grep base 12965206700.32285200_httpd.include
php_admin_value open_basedir /var/www/vhosts/wor.wordswithfriends.net/httpdocs/:/tmp/:/usr/share/pear/:/local/PEAR/
php_admin_value open_basedir /var/www/vhosts/wor.wordswithfriends.net/httpdocs/:/tmp/:/usr/share/pear/:/local/PEAR/
php_admin_value open_basedir /var/www/vhosts/wor.wordswithfriends.net/httpdocs/:/tmp/:/usr/share/pear/:/local/PEAR/
php_admin_value open_basedir /var/www/vhosts/wor.wordswithfriends.net/httpdocs/:/tmp/:/usr/share/pear/:/local/PEAR/

Configured vhost.conf as follows

<Directory /var/www/vhosts/wor.wordswithfriends.net/wordswithfriends.net>
<IfModule sapi_apache2.c>
php_admin_flag engine on
php_admin_flag safe_mode off
php_admin_value open_basedir "/var/www/vhosts/wor.wordswithfriends.net:/tmp:/usr/share/pear/local/PEAR"
</IfModule>
<IfModule mod_php5.c>
php_admin_flag engine on
php_admin_flag safe_mode off
php_admin_value open_basedir "/var/www/vhosts/wor.wordswithfriends.net:/tmp:/usr/share/pear:/local/PEAR"
</IfModule>
</Directory>

Restarted apache and the parameter is still the same. I'm not sure why my pear directories are not showing up. I'm using Plesk. Any help appreciated

share|improve this question
add comment

2 Answers

You have to recompile Plesk with the changes. You can do this using

/usr/local/psa/admin/sbin/websrvmng -v -a

on the command line, as root

share|improve this answer
add comment

Make a PHP file with this in it:

<?php
phpinfo();

View the file in the browser. It will tell you the location of the php.ini it's using.
Modify the php.ini's value for open_basedir and restart Apache.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.