Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Disclaimer : I'm novice in Oracle configuration and I want understand why it does not work.

Here is my configuration :

  • My local machine : Windows 7 Ultimate (x64)
  • My VM hosted on my local machine with VMPlayer 3.1.3 build-324285 : Windows Server 2003 Enterprise Edition

On the VM

On the VM, there is an Oracle 11g server. This server works fine, I executed some queries with Sql*Plus which is installed to the VM too.

The VM network configuration is : "Bridged" enter image description here

On the local machine

On the local machine (which host the VM), there is a SqlDeveloper installed. I want to connect it to the server hosted in the VM but I have this message :

The Network Adapter could not establish the connection.

It seems to be a network problem but, when I ping the VM from the local machine, it works and vice versa

Moreover SqlDeveloper is installed on the VM too (and works fine). The connection parameters are the same in the local machine SqlDeveloper except the hostname parameter.

I have tested with the IP adress and the computer name.

Which parameter should I check (and change) to resolve this problem ?

I hope to be clear in exposing my problem.

Thank you for your help !!!

share|improve this question
add comment

1 Answer 1

If you're using DHCP on the VM hosted oracle server, you'll need the Microsoft Loopback Adapter installed there as well, or at least manual editing of listener.ora and tnsnames.ora to use the static IP of 127.0.0.1. Here is more on the issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.