Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running an apache 2.17 at a Fedora 13. I did install phpmyadmin from the repos (via yum). It is installed in /usr/share/phpMyAdmin. I did make a symlink from my document root to the /user/share/phpMyadmin. I set 755 permsissions on that folder, set it to be owned by user apache and group apache.

And yet, when I try to open http://localhost/phpmyadmin, it gives me the 403 error - you do not have permisssion! I tried also commenting some deny lines in the phpMyAdmin.conf file, no success.

Any help would be gladly appreciated.

share|improve this question
add comment

2 Answers 2

  1. Delete symlink, don't do that again

  2. Edit /etc/httpd/conf.d/phpMyAdmin.conf:

    Replace Allow from 127.0.0.1 with your ip/or allow all: like this Allow from all

  3. Reload apache

share|improve this answer
    
oh, old post, fedora 13, but its fine –  GioMac Sep 20 '13 at 11:02
add comment

Do you have "Options FollowSymLinks" in your httpd.conf set? See: http://httpd.apache.org/docs/current/mod/core.html#directory

After making modifications to your httpd.conf file, reload or restart your apache server.

share|improve this answer
    
I did check this, and It was there, for the main directory entry. Anyway, I did reinstall phpMyAdmin from the repository, and it all became fine. –  George Feb 3 '11 at 9:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.