Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have my C:\Users\Mike\Projects directory registered for sharing in VirtualBox as "projects" (full access, permanent).

In my Ubuntu 10.04 server VM, I am using the following mount command:

sudo mount -t vboxsf -o uid=1000,gid=1000,rw,exec projects /home/mike/projects

The shared directory is mounted.

mike@zsce:~$ ll
drwxrwxrwx 1 mike mike 4.0K 2011-02-01 10:32 projects

If I create a file from Windows I can see and delete it on Ubuntu and vice-versa. So far, so good.

The problem is that I cannot do svn checkouts from the guest here.

mike@zsce:~/projects$ svn co svn://server/myproject/ ./myproject
svn: Can't move 'myproject/.svn/tmp/entries' to 'myproject/.svn/entries': Operation not permitted

My intention is to use the VM as a local development server. Use Windows 7 for all IDE/e-mail/web/etc needs and just use the server to test and commit my code. The Windows IDE and the VM's web server would be operating on the same source code.

However, the entries file ends up not being writable by me.

mike@zsce:~/projects/myproject/.svn$ ll entries
-r-xr-xr-x 1 mike mike 166 2011-02-01 10:34 entries

Even root cannot delete the files without first executing chmod -R 777.

What gives?

share|improve this question

upgrade to svn 1.7 and it will work. see link .

although it is a bug in vbox, but seems subversion team is actively fixing it...

share|improve this answer

A possible solution was posted here by lipi. But is is a hack-a-round.

For those desperately looking for a workaround, below is a hack I just added to svn_io_remove_file and svn_io_file_rename in subversion-1.6.12. It works for me but still needs dmode=755 in the mount options.

share|improve this answer
up vote 1 down vote accepted

I was unable to find a solution. Extensive Google search revealed other people had the same problem and were not able to find solutions either.

I ended up not using the Shared Folders feature of VirtualBox with vboxsf and instead just created a Windows share and mounted it under the Ubuntu VM.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.